Re: [dev] No rule to make target `/usr/local/lib/libixp.a'

From: Davide Anchisi <>
Date: Sat, 14 Nov 2009 23:20:17 +0100

That was the problem: I had libixp.a in /usr/lib/

 Thank you very much.


2009/11/13 Kris Maglione <>:
> On Tue, Nov 10, 2009 at 11:04:22AM +0100, Davide Anchisi wrote:
>> Hi,
>> I already posted a similar problem, but as it is still there and don't
>> know how to solve it, here it is.
>> When I run 'make' to compile wmii (hg2590), I get the following error:
>>  make[2]: *** No rule to make target `/usr/local/lib/libixp.a',
>> needed by `wmii.out'.  Stop.
>> I thought I'm missing something on my newly installed debian GNU/Linux
>> 64bit system, but I couldn't figure out what it is (and I have no
>> problemin  compiling other packages).
>> More strangely, if I run ' make deb' first, which fails as reported in
>> a previous mail, and then ' make clean', wmii compiles!
>> Then it installs ('make install') under debian/wmmi-hg (as in
>>, which is not removed by 'make clean'), and finally,
>> if I move those files by hand in the right location wmii is working
>> properly.
>> So it seems I have all the tools to compile.
> You need to install libixp, either to the same PREFIX as wmii or you need to
> change the LIBIXP variable to point to it.
> Unfortunately, I can't test on debian except to send my sources to the
> Launchpad build farm, and they always make clean first. I really can't see
> why there should be a problem.
> --
> Kris Maglione
> APL is a mistake, carried through to perfection.  It is the language
> of the future for the programming techniques of the past: it creates a
> new generation of coding bums.
>        --Edsger W. Dijkstra
Received on Sat Nov 14 2009 - 22:20:17 UTC

This archive was generated by hypermail 2.2.0 : Sat Nov 14 2009 - 22:24:02 UTC