Re: [dev] [sbase][patch] add [ alias to test, makefile cleanup

From: Nick <>
Date: Fri, 20 Feb 2015 23:36:21 +0000

Quoth Evan Gates:
> sbase-use_pe.diff : use parameter expansion instead of basename when
> building sbase-box. simpler, shorter, no extra processes

I don't like this. The sbase Makefile is a really standard, basic,
make at the moment (almost completely within the OpenGroup makefile
spec), and AFAIK builds basically everywhere as a result. Parameter
expansion is something I think of as a bashism, and I doubt is
available everywhere. To my eyes it's uglier too. Spawning an extra
process to call basename is less important than readability, though
of course to an extent that's in the eye of the beholder.

> sbase-align_redir.diff : cleanup the redirections for readability,
> move them outside of loops

I expected to dislike this, but actually it does make it more
readable, even though I don't like alignment like this in the
general case.

Received on Sat Feb 21 2015 - 00:36:21 CET

This archive was generated by hypermail 2.3.0 : Sat Feb 21 2015 - 00:48:07 CET