[dev] [sbase][patch] expr: comments, cleanup, style, etc.

From: Evan Gates <evan.gates_AT_gmail.com>
Date: Wed, 25 Feb 2015 20:20:18 -0800

Went back and added some comments to expr where I thought it would
benefit from extra explanation. Got rid of unnecessary allocations.
Used utfnlen() with the match operator to add UTF-8 support. Made some
changes for the style guide, then also rearranged a few things that
IMO make the code more readable.

I added a FIXME? comment. There is a strdup() that is never free()d.
Is it worth keeping track of it at a global level just to free when
we're done?

-emg

Received on Thu Feb 26 2015 - 05:20:18 CET

This archive was generated by hypermail 2.3.0 : Thu Feb 26 2015 - 05:24:07 CET