Re: [dev] Shell style guide

From: Adrian Grigore <>
Date: Thu, 8 Sep 2016 00:11:47 +0300

Rendering was just an example, I doubt a shell script would be rendering.

Example of camelCase I find ok is here:

Be free to critique the script, but note that I'm new to the whole
UNIX/C scene so learning as I go (if I did some blatant mistakes,
please point them).

On Thu, Sep 8, 2016 at 12:04 AM, Charlie Kester <> wrote:
> On Wed 07 Sep 2016 at 11:43:48 PDT Adrian Grigore wrote:
>> Tbh, I'm nor a big fan of camelCase either, but when dealing with
>> names composed of multiple words, it looks cleaner to me.
>> renderimage vs renderImage
> It's mostly a matter of taste. But as someone whose tastes
> were formed by the naming conventions of K&R and the C runtime
> library, I think the camelcased version of your example looks
> less "clean".
> And I have to ask: what else would your script be rendering?
> Is it really necessary to specify the object if "render" will
> suffice?

Received on Wed Sep 07 2016 - 23:11:47 CEST

This archive was generated by hypermail 2.3.0 : Wed Sep 07 2016 - 23:24:05 CEST