[wmii] overfull column redrawing

From: David Tweed <tweed314_AT_yahoo.co.uk>
Date: Tue, 23 May 2006 22:48:00 +0000 (GMT)

Hi, one of those semi-useless bug reports :-S

I've just tried in wmii-3 having my program medea open more windows than there is space for title bars within a column (in this case 61). Things initially seem "reasonable given that drawing more title bars than there is space for is tricky". However, __sometimes__ when I select a window and switch to max mode I end up with a garbled window draw (ie, it looks to have blocks of previous pixmaps, including title bar ones in it). If I move to another client using Alt-J/Alt-K I the window contents get drawn correctly. Likewise I've found that __sometimes__ in a column that's overfull but in max mode, one or two Alt-J/Alt-K moves result in the title bar changing as expected, but not in the window being redrawn. Finally (after generally no more than 3 or 4 Alt-J/Alt-K moves) the window does get redrawn with the correct contents.

I haven't figured out any common denominator about the times when these things occur compared to other times when the same action works ok.

I've tried to reproduce this with something common like an xterm, but it's difficult to automate opening up so many windows that in my experiments I haven't been able to replicate the above phenomenon yet. I know that it's the applications job to redraw itself, but I'm just wondering if something is intermittently going wrong with the receiving of requests to do a redraw by the fltk toolkit (which does all the actual drawing for medea)? FWIW, if I open up the same directory (ie, number of files) in a frame in Ion3 and move between windows using the keybindings, things redraw quickly enough for me to see it's updating correctly even if I bounce on the keybinding as fast as I can. So it's not that fltk/medea is incapable of redrawing quickly enough.

Unfortunately I remember that medea didn't build on OpenBSD (which I don't have any access to myself for fixing), so I'm not sure how you can reproduce this. It's 99.999% certain that it's acutally an fltk issue since medea doesn't do any X drawing directly, but I'm still not sure how to debug further?

cheers, dave tweed
Received on Wed May 24 2006 - 00:48:30 UTC

This archive was generated by hypermail 2.2.0 : Sun Jul 13 2008 - 16:06:41 UTC