Re: [dwm] quitting dwm-in-pipe

From: Antoni Grzymala <>
Date: Wed, 18 Oct 2006 20:23:33 +0200

Tako rzecze David Tweed (w liƛcie z 2006-10-18, 18:14):

> I'm really not sure what's going on then:
> 1. If I just run dwm directly I'm sure I often used M-S-q quit
> successfully back to xdm when I had open xterms.
> 2. If I run in the pipe and close all the clients and M-S-q then I
> stay in X.
> 3. Even dropping the sleep down to 4 seconds M-S-q hasn't caused X to
> quit after 5 minutes.
> 4. I'm trying this at work on a machine that's running whatever fedora
> uses (gdm-binary?), but it also didn't work on a machine with a two
> year older version of all software and where I go into a VC and then
> "startx".
> I'm sure it's something simple I'm doing wrong/been misconfigured, but
> I can't figure it out. The sleep timeout still applies, but obviously
> it's not the case :).
> Just to confirm it's my setup: anyone using Fedora 5 with gdm-thingy &
> running dwm in pipe: the quit action of dwm gets you back to the login
> screen, yes?

No, really it is just the matter of the loop. I'm running dwm on a
different system (Gentoo, gdm-2.16.1, xorg-x11-7.1), and it acts the

If I have a loop updating dwm I have to quit my xclients. If I don't it
exits immediately killing the clients (connection to xserver lost, they

That happens both whether I run dwm from .xinitrc via startx, or from an
identical dwm-session file from gdm-login-thingy.

So it's a design question that we should perhaps ask arg (arg, are you
reading this?).


. Antoni Grzymala - antoni (at) -------------------.
| OpenPGP KeyID EB315583 available now from a keyserver near you |
| Fingerprint A819 6D2E D5EB D9E0 D2D9  7AF6 2FAF 4A11 EB31 5583 |
Received on Wed Oct 18 2006 - 20:23:41 UTC

This archive was generated by hypermail 2.2.0 : Sun Jul 13 2008 - 14:32:06 UTC