hackers mail list archive by subject
- [hackers] [dwm] applied Hiltjo's resize/move limitation || Anselm R Garbe
- [hackers] [libsl] added missing LICENSE file || Anselm R Garbe
- [hackers] [quark] Add strftime to modified-date-check || FRIGN
- [hackers] [quark] Allow dir-listing to be a configurable option || FRIGN
- [hackers] [quark] cgi: parse Status: header || Hiltjo Posthuma
- [hackers] [quark] Change default mimetype to application/octet-stream || FRIGN
- [hackers] [quark] Change HTTP-status-codes to defines || FRIGN
- [hackers] [quark] Change tstamp() to allow passing time_t || FRIGN
- [hackers] [quark] check for len(reqbuf) = 0 || FRIGN
- [hackers] [quark] Coding style || FRIGN
- [hackers] [quark] Do not indent switch cases || sin
- [hackers] [quark] Don't let r be uninitialized || FRIGN
- [hackers] [quark] Ensure mod is properly initialized || sin
- [hackers] [quark] Fix mime-check || FRIGN
- [hackers] [quark] Fix mime-handling with default mime || FRIGN
- [hackers] [quark] Fix potentially uninitialized vars || sin
- [hackers] [quark] Fix streaming errors || FRIGN
- [hackers] [quark] Fixed buffer overflow when p-res==targetlen in function getreqentry || Adria Garriga
- [hackers] [quark] Fortify error-cases || FRIGN
- [hackers] [quark] Fortify the sanity-checks || FRIGN
- [hackers] [quark] Get rid of getnameinfo and use inet_ntop instead || FRIGN
- [hackers] [quark] HTTP 401 -> 403 || FRIGN
- [hackers] [quark] Ignore EPIPE while writing file to socket || FRIGN
- [hackers] [quark] Ignore SIGPIPE || sin
- [hackers] [quark] improve CGI support || Hiltjo Posthuma
- [hackers] [quark] Increase clarity of the len-check || FRIGN
- [hackers] [quark] No need for MAXBUFLEN+1 || sin
- [hackers] [quark] Rectify error-handling || FRIGN
- [hackers] [quark] Refactor loop inside writedata() || FRIGN
- [hackers] [quark] Refactor responsefile() || FRIGN
- [hackers] [quark] Refactor sighandler || FRIGN
- [hackers] [quark] Remove "_AT_strip $@" from the Makefile || FRIGN
- [hackers] [quark] Remove whitespace from manual || FRIGN
- [hackers] [quark] Rename fd to listenfd for readability || sin
- [hackers] [quark] Reordering function-prototypes and functions and size_t-correctness || FRIGN
- [hackers] [quark] request: ignore empty request in log || Hiltjo Posthuma
- [hackers] [quark] Revert "always null-terminate reqbuf buffer" || FRIGN
- [hackers] [quark] Revert "request: ignore empty request in log" || FRIGN
- [hackers] [quark] set host[0] = 0 at the beginning for more safety || FRIGN
- [hackers] [quark] small style and CGI message fix || Hiltjo Posthuma
- [hackers] [quark] Streamline the code || FRIGN
- [hackers] [quark] Unify return values || FRIGN
- [hackers] [quark] Use gmtime() instead of localtime() || FRIGN
- [hackers] [quark] Use named indices for the response-entry-array || FRIGN
- [hackers] [quark] Use ssize_t for read- and write-return-values || FRIGN
- [hackers] [quark] Use strsignal() for signal-logging || FRIGN
- [hackers] [sbase] cp: print error to stderr and continue || Hiltjo Posthuma
- [hackers] [sinit] Bump up to 0.9.1 || sin
- [hackers] [sinit] Remove -Wno-unused-result and -s || sin
- [hackers] [sinit] Remove -Wno-unused-result and add -s || sin
- [hackers] [sinit] Reword sinit manpage - clarify confusion around utmp entries. || sin
- [hackers] [sinit] Update link to initscripts || sin
- [hackers] [smdev] Add Hiltjo Posthuma to LICENSE || sin
- [hackers] [smdev] Add TODO || sin
- [hackers] [smdev] Bump to 0.2.1 || sin
- [hackers] [smdev] No need for enprintf(1, ...) just use eprintf() || sin
- [hackers] [smdev] Update TODO || sin
- [hackers] [smdev] Use OpenBSD strlcpy() || sin
- [hackers] [st] Add error message when child exits whit error || Roberto E. Vargas Caballero
- [hackers] [st] Add eschandle() || Roberto E. Vargas Caballero
- [hackers] [st] Change the behavior of word snapping on delimiters || Ivan Delalande
- [hackers] [st] Convert VT102ID to a config variable || Roberto E. Vargas Caballero
- [hackers] [st] Don't set dirty all lines because tswapcreen do it || noname
- [hackers] [st] Fix definition of CONTROLC0 || Roberto E. Vargas Caballero
- [hackers] [st] Fix man page and usage() || Roberto E. Vargas Caballero
- [hackers] [st] Fix portability problem in techo() || Roberto E. Vargas Caballero
- [hackers] [st] Improve execsh() and don't allow anonymous shells || Roberto E. Vargas Caballero
- [hackers] [st] Improve readability of enum members || Alexander Huemer
- [hackers] [st] Make useful DEL in application mode || Roberto E. Vargas Caballero
- [hackers] [st] Move calls to selsnap into selnormalize || Ivan Delalande
- [hackers] [st] Remove ul capability || Roberto E. Vargas Caballero
- [hackers] [st] Removing wrapping newlines from selection || Ben Hendrickson
- [hackers] [st] reset the alt screen in treset || Quentin Carbonneaux
- [hackers] [st] simplify loop in tresize || Quentin Carbonneaux
- [hackers] [st] Simplify README || Alexander Huemer
- [hackers] [st] tresize return value is not used || noname
- [hackers] [st] Unset mode when clearing regions || Roberto E. Vargas Caballero
- [hackers] [surf] Add a FAQ to surf. || Christoph Lohmann
- [hackers] [surf] Mention xdotool in SEE ALSO too. || Christoph Lohmann
- [hackers] [tabbed] Clear urgency hint on sel == c || Peter Hofmann
- [hackers] [ubase] Add lastlog to README || sin
- [hackers] [ubase] Add lastlog(8) || Roberto E. Vargas Caballero
- [hackers] [ubase] Add mesg.1 || sin
- [hackers] [ubase] Associate perms on stderr as opposed to stdin || sin
- [hackers] [ubase] Check for cmd truncation in watch(1) || sin
- [hackers] [ubase] Convert lastlog(8) to {w,}eprintf() || sin
- [hackers] [ubase] Only check errno if getpwnam() fails || sin
- [hackers] [ubase] Only work with stderr in mesg || sin
- [hackers] [ubase] Remove unnecessary newline output from su || Wolfgang Corcoran-Mathe
- [hackers] [ubase] Rework parsecmdline() || sin
- [hackers] [ubase] Use agetline() in lastlog(8) || sin
- [hackers] [utmp] Avoid race conditions between fork and wait || Roberto E. Vargas Caballero
- [hackers] [utmp] Pass name of shell as first parameter of child process || Roberto E. Vargas Caballero
- [hackers] [utmp] Remove duplicated inclusion of utmp.h || Roberto E. Vargas Caballero
- [hackers] [utmp] Remove unneeded ctype.h header || Roberto E. Vargas Caballero
- [hackers] [utmp] Return the status of child as status of utmp || Roberto E. Vargas Caballero
- Last message date: Tue Aug 26 2014 - 07:13:25 CEST
- Archived on: Thu Nov 21 2024 - 10:36:46 CET