hackers mail list archive by subject
- [hackers] [dev] [st] [patch] argbbg diff for st-0.5
- [hackers] [quark] correct information in README || Jakob Kramer
- [hackers] [sandy] Minor typo fix by joshua_AT_cubesolving.com || Rafael GarcĂa Gallego
- [hackers] [sbase] Add -D_GNU_SOURCE to config.mk for tcc || sin
- [hackers] [sbase] chmod: process file series behaviour || Hiltjo Posthuma
- [hackers] [sbase] chown: add -R for compatability || Hiltjo Posthuma
- [hackers] [sbase] chown: fix out-of-bounds ((null) bad address error) || Hiltjo Posthuma
- [hackers] [sbase] chown: return EXIT_FAILURE if one file failed. || Hiltjo Posthuma
- [hackers] [sbase] cmp: dont output EOF difference is sflag is set || Hiltjo Posthuma
- [hackers] [sbase] cmp: fix line numbers || Hiltjo Posthuma
- [hackers] [sbase] cmp: fix missing braces || Hiltjo Posthuma
- [hackers] [sbase] cmp: fix wrong rebase, missing line, sorry || Hiltjo Posthuma
- [hackers] [sbase] cmp: make EOF check more clear || Hiltjo Posthuma
- [hackers] [sbase] cmp: suppress file open error with sflag || Hiltjo Posthuma
- [hackers] [sbase] Don't bail out if chmod(2) or chown(2) fails || sin
- [hackers] [sbase] Don't bail out if the username/group name does not exist in ls(1) || sin
- [hackers] [sbase] Fix char **argv to char *argv[] || sin
- [hackers] [sbase] Fix missing '-' in usage || sin
- [hackers] [sbase] Fix style issue in crypt.c || sin
- [hackers] [sbase] keep usage definition above main || dwts
- [hackers] [sbase] make parsemode() generic || Hiltjo Posthuma
- [hackers] [sbase] Minor style changes to sort || sin
- [hackers] [sbase] minor style changes || dwts
- [hackers] [sbase] No need to cast return value of mmap() in tr || sin
- [hackers] [sbase] parsemode: rework || Hiltjo Posthuma
- [hackers] [sbase] Rename variable `dif' to `diff' in comm(1) || sin
- [hackers] [sbase] sort: add -k, fix -u || Jakob Kramer
- [hackers] [sbase] sort: readability; check strndup return value || Jakob Kramer
- [hackers] [sbase] sort: style, explicitly state type || Hiltjo Posthuma
- [hackers] [sbase] split: dont use table lookup for size || Hiltjo Posthuma
- [hackers] [sbase] style: whitespace fixes || Hiltjo Posthuma
- [hackers] [sbase] tr: add dflag, error with usage() on invalid flag combination || Hiltjo Posthuma
- [hackers] [sbase] tr: change delete behaviour || Hiltjo Posthuma
- [hackers] [sbase] tr: fix escape code handling in set2 || Hiltjo Posthuma
- [hackers] [sbase] update some man pages || Hiltjo Posthuma
- [hackers] [sbase] update TODO file || Hiltjo Posthuma
- [hackers] [sbase] Update tr.1 man page || Silvan Jegen
- [hackers] [sbase] use always static for usage and keep usage definition above main || dwts
- [hackers] [sbase] Wrap mbtowc to check for errors || Silvan Jegen
- [hackers] [sbase] xargs: implement -n || Hiltjo Posthuma
- [hackers] [sinit] Add dist target to Makefile || sin
- [hackers] [sinit] Add sinit.8 manpage || sin
- [hackers] [sinit] Break on first signal found || sin
- [hackers] [sinit] Mention /bin/rc.init in the manpage || sin
- [hackers] [sinit] setpgid(0, 0) seems redundant after setsid() || sin
- [hackers] [st] 0.5 release. || Christoph Lohmann
- [hackers] [st] add break;s for last cases in switch statements || Markus Teich
- [hackers] [st] Add missing function prototypes. || noname
- [hackers] [st] Cancel DCS with SUB, CAN, ESC or any CC1 code || Roberto E. Vargas Caballero
- [hackers] [st] Comment fix. || noname
- [hackers] [st] Compute ena_sel as one expression. || noname
- [hackers] [st] Conformity in the -g geometry handling. || Christoph Lohmann
- [hackers] [st] Create a function for DEC test || Roberto E. Vargas Caballero
- [hackers] [st] Do not eat ESC character if control string is not properly terminated. || noname
- [hackers] [st] Do not export chscale and cwscale. || noname
- [hackers] [st] Do not save cursor in tresize. || noname
- [hackers] [st] Do not set dirty flag twice in tscrollup and tscrolldown. || noname
- [hackers] [st] fix cursor handling when alt screen is disabled || q_AT_c9x.me
- [hackers] [st] Fix displaying control code || Roberto E. Vargas Caballero
- [hackers] [st] Fix for multibyte characters in techo. || noname
- [hackers] [st] Fix misplaced break || Roberto E. Vargas Caballero
- [hackers] [st] Fix segfault when pressing PrintScr without a selection || Rafa Garcia Gallego
- [hackers] [st] Fix techo handling of control and multibyte characters. || noname
- [hackers] [st] Fix tputc control code handling || Roberto E. Vargas Caballero
- [hackers] [st] Fixing a compiler warning with the assignment. || Christoph Lohmann
- [hackers] [st] It's 2014 now. || Christoph Lohmann
- [hackers] [st] Make xrealloc and xstrdup style consistent. || noname
- [hackers] [st] Merge remote-tracking branch 'origin/master' into omaster || Roberto E. Vargas Caballero
- [hackers] [st] misplaced parenthesis in LEN macro || noname_AT_inventati.org
- [hackers] [st] move MODBIT to Macros section || noname_AT_inventati.org
- [hackers] [st] new utf decoder || Damian Okrasa
- [hackers] [st] On terminal resize, clear the alt screen with its own cursor. || Colona
- [hackers] [st] Optimize tputtab. || noname
- [hackers] [st] Remove argument names from function prototypes. || noname
- [hackers] [st] Remove ATTR_GFX and tselcs || Roberto E. Vargas Caballero
- [hackers] [st] remove confusing SERRNO macro || Markus Teich
- [hackers] [st] Remove one indentation level in getsel(). || noname
- [hackers] [st] Remove unnecessary break || noname
- [hackers] [st] Remove unused dump() function. || noname
- [hackers] [st] Removing two unnecessary gettimeofday(). || Christoph Lohmann
- [hackers] [st] s/DSC/DCS/ DCS stands for DEVICE CONTROL STRING || noname
- [hackers] [st] Simplify a bit more tdeletechar and tinsertblank || Roberto E. Vargas Caballero
- [hackers] [st] Simplify expressions in tputc() || Roberto E. Vargas Caballero
- [hackers] [st] Simplify selected(). || noname
- [hackers] [st] Simplify techo || noname_AT_inventati.org
- [hackers] [st] Simplify xunloadfonts. || noname
- [hackers] [st] Style fix in tdumpsel. || noname
- [hackers] [st] Style fixes in tscrollup. || noname
- [hackers] [st] There is no need for a full dirt redraw. || Christoph Lohmann
- [hackers] [st] typedefs instead of #defines || noname_AT_inventati.org
- [hackers] [st] Use != instead of ^ for logical values. || noname
- [hackers] [st] Use BETWEEN in tinsertblankline and tdeleteline. || noname
- [hackers] [st] Use BETWEEN in tsetchar. || noname
- [hackers] [st] Use BETWEEN macro in xsetcolorname and fix style. || noname
- [hackers] [st] Use MODBIT in xseturgency. || noname
- [hackers] [st] Use tsetdirt in tscrollup and tscrolldown. || noname
- [hackers] [st] Use uint and uchar instead of unsigned int and unsigned char. || noname
- [hackers] [st] Use xwrite instead of write. || noname
- [hackers] [ubase] Add -s to LDFLAGS || sin
- [hackers] [ubase] Add a SEE ALSO section for the umount manpage || sin
- [hackers] [ubase] Add commented out # -static in config.mk || sin
- [hackers] [ubase] Add ctrlaltdel manpage || sin
- [hackers] [ubase] Add dd to TODO || sin
- [hackers] [ubase] Add dmesg manpage and fix dmesg usage || sin
- [hackers] [ubase] Add ealloc.c with wrappers for emalloc() and friends || sin
- [hackers] [ubase] Add explicit_bzero() in util/ || sin
- [hackers] [ubase] Add fallocate manpage || sin
- [hackers] [ubase] Add free manpage || sin
- [hackers] [ubase] Add getty manpage || sin
- [hackers] [ubase] Add initial implementation of sysctl(8) || sin
- [hackers] [ubase] Add insmod manpage and fix insmod usage || sin
- [hackers] [ubase] Add killall5 manpage || sin
- [hackers] [ubase] Add LICENSE header in explicit_bzero.c || sin
- [hackers] [ubase] Add manpages to Makefile || sin
- [hackers] [ubase] Add mkswap manpage || sin
- [hackers] [ubase] add more info to unshare.1 || dwts
- [hackers] [ubase] Add mount manpage || sin
- [hackers] [ubase] Add mountpoint manpage || sin
- [hackers] [ubase] Add pagesize manpage || sin
- [hackers] [ubase] Add pidof manpage || sin
- [hackers] [ubase] Add ps manpage || sin
- [hackers] [ubase] Add random replies for failed password attempts in su(1) || sin
- [hackers] [ubase] Add respawn to README || sin
- [hackers] [ubase] Add respawn || sin
- [hackers] [ubase] Add rmmod manpage || sin
- [hackers] [ubase] Add su manpage and fix su usage line || sin
- [hackers] [ubase] Add switch_root manpage || FRIGN
- [hackers] [ubase] Add switch_root to README || sin
- [hackers] [ubase] Add truncate manpage || sin
- [hackers] [ubase] Add umount manpage and fix umount usage || sin
- [hackers] [ubase] add unshare.1, swapon.8, swapoff.8 and update df.1 || s-p-k
- [hackers] [ubase] Add uptime manpage || sin
- [hackers] [ubase] Add watch manpage || sin
- [hackers] [ubase] Be consistent with the escape sequences in the manpages || sin
- [hackers] [ubase] Break line in mknod.1 || sin
- [hackers] [ubase] Capitalize the one-line description in manpages || sin
- [hackers] [ubase] Don't hardcode the buffer size in sysctl || sin
- [hackers] [ubase] Don't leak `buf' if realloc fails || sin
- [hackers] [ubase] Don't prefix error messages with the program name || sin
- [hackers] [ubase] Error out if dup2 doesn't return the fd we want || sin
- [hackers] [ubase] Error out if there are multiple separators in sysctl || sin
- [hackers] [ubase] Fix char **argv to char *argv[] || sin
- [hackers] [ubase] Fix manpage style || sin
- [hackers] [ubase] Fix some more inconsistencies || sin
- [hackers] [ubase] Fix typo || sin
- [hackers] [ubase] Fix uptime manpage || sin
- [hackers] [ubase] Fixup error message in switch_root || sin
- [hackers] [ubase] For consistency with other similar constructs in ubase || sin
- [hackers] [ubase] Forgot SEE ALSO in who.1 || sin
- [hackers] [ubase] If at least one entry fails, return EXIT_FAILURE in sysctl || sin
- [hackers] [ubase] Implement fifo listener mode for respawn || sin
- [hackers] [ubase] Implement streplace() || sin
- [hackers] [ubase] Implement switch_root || FRIGN
- [hackers] [ubase] Include limits.h instead of linux/limits.h || sin
- [hackers] [ubase] Initialize size to 0 to avoid gcc warnings || sin
- [hackers] [ubase] Inlcude <string.h> as well for strcmp() || sin
- [hackers] [ubase] Inline the *_MAGIC defines to avoid a dependency on kernel_headers || sin
- [hackers] [ubase] keep usage definition above main in ubase || dwts
- [hackers] [ubase] Manpage overhaul || sin
- [hackers] [ubase] Minor stylisic changes to manpages || sin
- [hackers] [ubase] mount: add defaults option, it does nothing || Hiltjo Posthuma
- [hackers] [ubase] mount: cat /proc/mounts if no arguments given || Hiltjo Posthuma
- [hackers] [ubase] mount: loop until no opt options || Hiltjo Posthuma
- [hackers] [ubase] mount: rename bufsiz to datasiz for clarity || Hiltjo Posthuma
- [hackers] [ubase] mount: style for loop in catfile() || Hiltjo Posthuma
- [hackers] [ubase] No need for a temporary variable in streplace() || sin
- [hackers] [ubase] Remember to convert '/' back to '.' in sysctl before returning || sin
- [hackers] [ubase] Remember to return EXIT_FAILURE from main() || sin
- [hackers] [ubase] Remove -Os from config.mk || sin
- [hackers] [ubase] Remove implemented items from TODO || sin
- [hackers] [ubase] rmmod: fix segfault if '.' is not found || Hiltjo Posthuma
- [hackers] [ubase] Simplify config.mk and update README for tcc || sin
- [hackers] [ubase] Simplify skipping "." and ".." in switch_root || sin
- [hackers] [ubase] Some more stylistic changes to switch_root || sin
- [hackers] [ubase] stat: declare initial functions to use at the top || Hiltjo Posthuma
- [hackers] [ubase] stat: implement -t (terse mode) || Hiltjo Posthuma
- [hackers] [ubase] Style fix for respawn || sin
- [hackers] [ubase] su: zero out encrypted passwords || Jakob Kramer
- [hackers] [ubase] Sweep through code and replace malloc() with emalloc() etc. || sin
- [hackers] [ubase] update who.1 to list the -l option || dwts
- [hackers] [ubase] Use *_FILENO instead of hardcoding constants || sin
- [hackers] [ubase] Use explicit_bzero() in su || sin
- [hackers] [ubase] Use streplace() in setsysctl() as well || sin
- [hackers] [ubase] variable cannot be NULL so don't test for that || sin
- Last message date: Wed Apr 30 2014 - 16:17:05 CEST
- Archived on: Thu Nov 21 2024 - 10:48:46 CET