hackers mail list archive by subject
- [hackers] [farbfeld] add arg.h (needed for ff2ppm) || Hiltjo Posthuma
- [hackers] [farbfeld] add ff2ppm(1) || Hiltjo Posthuma
- [hackers] [farbfeld] Add proper blank lines in png2ff(1) before comments || FRIGN
- [hackers] [farbfeld] Bump version to 2 || FRIGN
- [hackers] [farbfeld] Fix 2 little things in jpg2ff(1) || FRIGN
- [hackers] [farbfeld] Fix 2ff || FRIGN
- [hackers] [farbfeld] Optimize ff2ppm(1) || FRIGN
- [hackers] [farbfeld] Prevent overflow in rowlen and improve inaccuracies in style || FRIGN
- [hackers] [farbfeld] Use uint32-array to store the header || FRIGN
- [hackers] [farbfeld] Use uint8_t instead of uint16_t correctly || FRIGN
- [hackers] [farbfeld] Write a better format for the row-buffer allocation || FRIGN
- [hackers] [libzahl] -O3 seem to produce fastest binary || Mattias Andrée
- [hackers] [libzahl] 64 bits (severely) outshines 16 bits and 8 bits in performance: do some cleanup || Mattias Andrée
- [hackers] [libzahl] 64-bit chars out-perform 32-bit chars on almost all operations, and on all expensive operations || Mattias Andrée
- [hackers] [libzahl] A brief description of exponentiation by squaring || Mattias Andrée
- [hackers] [libzahl] A description of the Karatsuba algorithm || Mattias Andrée
- [hackers] [libzahl] Add .gitignore || Mattias Andrée
- [hackers] [libzahl] Add makefile and fix errors || Mattias Andrée
- [hackers] [libzahl] Add memory pool, also let the user know that libzahl is not designed for cryptography || Mattias Andrée
- [hackers] [libzahl] Add more man pages || Mattias Andrée
- [hackers] [libzahl] Add new functions: zpowu and zmodpowu || Mattias Andrée
- [hackers] [libzahl] Add note on performance of commutative functions with assignment to operand || Mattias Andrée
- [hackers] [libzahl] Add possibility to compare against libgmp || Mattias Andrée
- [hackers] [libzahl] Add possibility to compare against libtommath || Mattias Andrée
- [hackers] [libzahl] Add rand(3), lrand(3), and random(3) to zrand || Mattias Andrée
- [hackers] [libzahl] Add reference to clang bug report || Mattias Andrée
- [hackers] [libzahl] Add simple benchmarker || Mattias Andrée
- [hackers] [libzahl] Add typedef zahl_char_t for internal use || Mattias Andrée
- [hackers] [libzahl] Add zabs, zadd, zdiv, zmod, zmodmul, zmodpow, zneg, zpow, zsub, and the newly introduced zmodsqr || Mattias Andrée
- [hackers] [libzahl] Add zahl.h || Mattias Andrée
- [hackers] [libzahl] Add zand, zor, zxor, znot, zbtest, zsplit, and the newly introduced ztrunc || Mattias Andrée
- [hackers] [libzahl] Add zbset || Mattias Andrée
- [hackers] [libzahl] Add zcmp, zcmpi, zcmpu, zcmpmag, zset, zseti, and zsetu || Mattias Andrée
- [hackers] [libzahl] Add zdivmod || Mattias Andrée
- [hackers] [libzahl] Add zgcd || Mattias Andrée
- [hackers] [libzahl] Add zlsh and zrsh || Mattias Andrée
- [hackers] [libzahl] Add zmul and zsqr || Mattias Andrée
- [hackers] [libzahl] Add zptest || Mattias Andrée
- [hackers] [libzahl] Add zrand || Mattias Andrée
- [hackers] [libzahl] Add zsets and zstr || Mattias Andrée
- [hackers] [libzahl] Add zsetup, zunsetup, zinit, zfree, zswap, zsave, zload, zbits, and zlsb || Mattias Andrée
- [hackers] [libzahl] Avoid using the internal structure as much as possible || Mattias Andrée
- [hackers] [libzahl] Clean up || Mattias Andrée
- [hackers] [libzahl] Clean up, add zerror and zperror, fix bugs and add more tests || Mattias Andrée
- [hackers] [libzahl] Clean up, fix a few bugs, and add a test || Mattias Andrée
- [hackers] [libzahl] Cleaner workaround for clang bug || Mattias Andrée
- [hackers] [libzahl] Cleanup and add missing header inclusions || Mattias Andrée
- [hackers] [libzahl] Cleanup and fix bug in ztrunc || Mattias Andrée
- [hackers] [libzahl] Fix another typo || Mattias Andrée
- [hackers] [libzahl] Fix bug in libzahl_msb_nz_* and optimise and simplify libzahl_realloc || Mattias Andrée
- [hackers] [libzahl] Fix bugs and add a randomised testing || Mattias Andrée
- [hackers] [libzahl] Fix example in comments
- [hackers] [libzahl] Fix so that no workaround is required. || Mattias Andrée
- [hackers] [libzahl] Fix typo || Mattias Andrée
- [hackers] [libzahl] Fix whitespace || Mattias Andrée
- [hackers] [libzahl] Improve zsub, only copy to temp when necessary || Mattias Andrée
- [hackers] [libzahl] Make zabs, zneg and zswap inline || Mattias Andrée
- [hackers] [libzahl] Makefile: add check rule || Mattias Andrée
- [hackers] [libzahl] Makefile: add install and uninstall || Mattias Andrée
- [hackers] [libzahl] Man pages: rationale for non-essential arithmetic functions || Mattias Andrée
- [hackers] [libzahl] More detailed description of division and modulus || Mattias Andrée
- [hackers] [libzahl] Mostly optimisations || Mattias Andrée
- [hackers] [libzahl] Multiple changes: || Mattias Andrée
- [hackers] [libzahl] Optimisations || Mattias Andrée
- [hackers] [libzahl] Optimise zdivmod || Mattias Andrée
- [hackers] [libzahl] Optimise zpow and zmodpow || Mattias Andrée
- [hackers] [libzahl] Optimise zsetup, zgcd, zmul, and zsqr and add -flto || Mattias Andrée
- [hackers] [libzahl] Optimise zsqr, and optimise zmul a little || Mattias Andrée
- [hackers] [libzahl] Optimise zsqr, zmul, zstr, zdivmod, zpow, and zpowu || Mattias Andrée
- [hackers] [libzahl] Optimise zswap || Mattias Andrée
- [hackers] [libzahl] Optimised zdivmod || Mattias Andrée
- [hackers] [libzahl] Remove unnecessary trim || Mattias Andrée
- [hackers] [libzahl] Rename zsplit_unsigned_fast_small_tainted to zsplit_unsigned_fast_small_auto || Mattias Andrée
- [hackers] [libzahl] Since zstr_length is a generalisation of zbits, add reference to each other in the man pages || Mattias Andrée
- [hackers] [libzahl] Why zbits returns 1 for 0 || Mattias Andrée
- [hackers] [libzahl] zahl.h: fix working mishapp for zptest || Mattias Andrée
- [hackers] [libzahl] zgcd: optimisation of the first loop || Mattias Andrée
- [hackers] [libzahl] zinit is now an inline function || Mattias Andrée
- [hackers] [libzahl] znot man page: notes on representation and tendness toward zero || Mattias Andrée
- [hackers] [libzahl] zrand: add DEFAULT_RANDOM and FASTEST_RANDOM || Mattias Andrée
- [hackers] [libzahl] zrand: add MODUNIFORM and add tests for QUASIUNIFORM and MODUNIFORM || Mattias Andrée
- [hackers] [libzahl] zsets: minor optimisation || Mattias Andrée
- [hackers] [libzahl] zsetu: change macro from CHARS_PER_TYPE to SIZE_MULTIPLE || Mattias Andrée
- [hackers] [libzahl] zstr_length_positive is safe for non-positive, hence rename to zstr_length; and add zstr_length || Mattias Andrée
- [hackers] [libzahl] ztrunc: fix bug: bits > .used may lead to incorrect truncation || Mattias Andrée
- [hackers] [sbase] *sum: support - when using -c || Mattias Andrée
- [hackers] [sbase] Actually move past the field separator || FRIGN
- [hackers] [sbase] Add linecmp() || FRIGN
- [hackers] [sbase] cat: fix u flag || Quentin Rameau
- [hackers] [sbase] Change paste(1) a bit to prepare libutf changes || FRIGN
- [hackers] [sbase] Don't mark cols(1) as NUL-compliant as of yet || FRIGN
- [hackers] [sbase] Error out when giving an empty delimiter to sort(1) || FRIGN
- [hackers] [sbase] Fix -s in tr(1) || FRIGN
- [hackers] [sbase] Fix linecmp() to return correct values || FRIGN
- [hackers] [sbase] Indent README headings properly || FRIGN
- [hackers] [sbase] logger(1) is NUL compliant || FRIGN
- [hackers] [sbase] ls: fix segfault when timestamp is negative
- [hackers] [sbase] No need for += when res is 0 anyway || FRIGN
- [hackers] [sbase] printf: remove unnecessary string size test || Quentin Rameau
- [hackers] [sbase] printf: replace strtonum with strtol functions in conversions || Quentin Rameau
- [hackers] [sbase] Properly increment line lenght on edge-case in getlines() || FRIGN
- [hackers] [sbase] Properly use delimlen instead of len in paste(1) || FRIGN
- [hackers] [sbase] Really force 1 entry per line with -1 in ls(1) || FRIGN
- [hackers] [sbase] Remove debug info || FRIGN
- [hackers] [sbase] Rename linecmp and line-structs in join(1) and sort(1) || FRIGN
- [hackers] [sbase] Rename struct linebufline to struct line and add linecmp() || FRIGN
- [hackers] [sbase] Revert "fix length after '\' getline string termination" || sin
- [hackers] [sbase] sort: Fix -c option || Michael Forney
- [hackers] [sbase] Support NUL containing lines in comm(1) || FRIGN
- [hackers] [sbase] Support NUL containing lines in cut(1) || FRIGN
- [hackers] [sbase] Support NUL containing lines in fold(1) and reuse the line-buffer(!) || FRIGN
- [hackers] [sbase] Support NUL containing lines in head(1) || FRIGN
- [hackers] [sbase] Support NUL containing lines in join(1) || FRIGN
- [hackers] [sbase] Support NUL containing lines in nl(1) and reuse the line-buffer(!) || FRIGN
- [hackers] [sbase] Support NUL containing lines in tail(1) || FRIGN
- [hackers] [sbase] Support NUL containing lines in uniq(1) || FRIGN
- [hackers] [sbase] Support NUL-containing lines in cols(1) || FRIGN
- [hackers] [sbase] Support NUL-containing lines in sort(1) || FRIGN
- [hackers] [sbase] test: add -k, -ef, -ot, and -nt || Mattias Andrée
- [hackers] [sbase] test: add support for big integers || Mattias Andrée
- [hackers] [sbase] test: Remove unused variable || sin
- [hackers] [sbase] test: Sort includes || sin
- [hackers] [sbase] uniq: always store previous line length || Eivind Uggedal
- [hackers] [sbase] Use the UTF8_POINT macro in cols(1) || FRIGN
- [hackers] [sbase] uudecode: dont return pointer to local variable || Hiltjo Posthuma
- [hackers] [sbase] uuencode: style: just use pointer *b || Hiltjo Posthuma
- [hackers] [sbase] xargs(1) already supports NUL characters || FRIGN
- [hackers] [sbase][PATCH 1/2] test: add -k, -ef, -ot, and -nt
- [hackers] [sbase][PATCH 2/2] test: add support for big integers
- [hackers] [sbase][PATCH v2.1] ls: fix segfault when timestamp is out of range for struct tm
- [hackers] [sbase][PATCH v2.2] ls: fix segfault when timestamp is out of range for struct tm
- [hackers] [sbase][PATCH v2] ls: fix segfault when timestamp is negative
- [hackers] [sbase][PATCH v2] test: -erwx test against effetive uid/gid, not real
- [hackers] [sbase][PATCH v4] Add diff(1) and bdiff(1)
- [hackers] [sbase][PATCH] *sum: support - when using -c
- [hackers] [sbase][PATCH] Add base64(1), base32(1), and base16(1)
- [hackers] [sbase][PATCH] Add patch(1)
- [hackers] [sbase][PATCH] Add rev(1)
- [hackers] [sbase][PATCH] Add see also section to cat.1 and tac.1
- [hackers] [sbase][PATCH] Add shuf(1)
- [hackers] [sbase][PATCH] Add tac(1)
- [hackers] [sbase][PATCH] base32, base16: fix bugs
- [hackers] [sbase][PATCH] basename, dirname, printf: recognise -- and fail if options are used.
- [hackers] [sbase][PATCH] diff: minor simplification, and fix exit value bug
- [hackers] [sbase][PATCH] diff: Remove support for coloured output and do not refer to -e in description of -f
- [hackers] [sbase][PATCH] find: check whether readdir failed, and fix pri_[acm]time
- [hackers] [sbase][PATCH] grep -r: avoid loops
- [hackers] [sbase][PATCH] grep: add -r
- [hackers] [sbase][PATCH] grep: remove = flag from readme
- [hackers] [sbase][PATCH] Improvements to sleep(1):
- [hackers] [sbase][PATCH] ls: fix segfault when timestamp is negative
- [hackers] [sbase][PATCH] Move setsid to ubase
- [hackers] [sbase][PATCH] patch: fix bug
- [hackers] [sbase][PATCH] pathchk: fixes and cleanup
- [hackers] [sbase][PATCH] printenv: exit status is 2 on failure
- [hackers] [sbase][PATCH] Realloc variants should not fail if the requested size is zero
- [hackers] [sbase][PATCH] rm.1: list shred(1) under see also
- [hackers] [sbase][PATCH] shuf.1 and sort.1: reference each other under see also
- [hackers] [sbase][PATCH] shuf: fix possible infinite loop
- [hackers] [sbase][PATCH] sleep: Support omitted 0 before ., and . without trailing digits.
- [hackers] [sbase][PATCH] stty belongs in ubase
- [hackers] [sbase][PATCH] test: -erwx test against effetive uid/gid, not real
- [hackers] [sbase][PATCH] test: add -E
- [hackers] [sbase][PATCH] Update test.1:
- [hackers] [scc] [cc2] Change addnode() to addstmt() || Roberto E. Vargas Caballero
- [hackers] [scc] [cc2] change label() + allocdata() to defsym() || Roberto E. Vargas Caballero
- [hackers] [scc] [cc2] Fix small withespace problem || Roberto E. Vargas Caballero
- [hackers] [scc] [cc2] Remove label() from the target interface || Roberto E. Vargas Caballero
- [hackers] [scc] Add multi-clean target to Makefile || Roberto E. Vargas Caballero
- [hackers] [scc] Add skeleton for qbe backend || Roberto E. Vargas Caballero
- [hackers] [scc] Compile library in multi target || Roberto E. Vargas Caballero
- [hackers] [scc] Fix generic arch Makefile target || Roberto E. Vargas Caballero
- [hackers] [scc] Small withespace change || Roberto E. Vargas Caballero
- [hackers] [sent] Fix cmdline argument check
- [hackers] [sent] Fix cmdline argument check || Markus Teich
- [hackers] [sent] fix include and lib paths for the BSDs || Markus Teich
- [hackers] [sent] Import arg.h OOB fix from Lucas Gabriel Vuotto. || Markus Teich
- [hackers] [sent] support FreeBSD || Markus Teich
- [hackers] [st] Fix vertical character alignment in some cases || Ton van den Heuvel
- [hackers] [st] I like empty lines. || Christoph Lohmann
- [hackers] [st] Measure the single advance width with a heuristic method || Ryusei Yamaguchi
- [hackers] [st] st: Fix off-by-one error when calculating character width. || Tor Andersson
- [hackers] [st] xtermclear() is now done by xdrawglyphfontspecs() || Christoph Lohmann
- [hackers] [surf] Disable globbing in curl command || Dmitrij D. Czarkoff
- [hackers] [surf] Disable globbing in curl. || Christoph Lohmann
- [hackers] [surf] Get rid of JavaScript for scrolling in views || Quentin Rameau
- [hackers] [surf] Import the arg.h from st which fixed the oob bug. || Christoph Lohmann
- [hackers] [surf] Modify linking parameter || Quentin Rameau
- [hackers] [tabbed] [PATCH] add -k to close tabbed foreground client on WMDelete
- [hackers] [tabbed] add -k to close tabbed foreground client on WMDelete || Justin Keogh
- [hackers] [ubase] Add nologin(8) || Mattias Andrée
- [hackers] [ubase] dd: allow count=0 || Eivind Uggedal
- [hackers] [ubase] dd: always create of= even if seek= is used || Eivind Uggedal
- [hackers] [ubase] dd: don't let failure to change pipe size affect exit code || Eivind Uggedal
- [hackers] [ubase] dd: implement conv=notrunc support || Eivind Uggedal
- [hackers] [ubase] dd: remove if= noatime optimization || Eivind Uggedal
- [hackers] [ubase] dd: truncate file when using seek= || Eivind Uggedal
- [hackers] [ubase] fsfreeze: make it clear the either -f or -u must be specified, not optional || Mattias Andrée
- [hackers] [ubase] nologin: Sort includes || sin
- [hackers] [ubase][PATCH 1/3] stty: cleaner output when no arguments are used
- [hackers] [ubase][PATCH 2/3] stty: fix casting bug
- [hackers] [ubase][PATCH 3/3] stty: add symbolic values for line disciplines
- [hackers] [ubase][PATCH v2] Add pwdx(1)
- [hackers] [ubase][PATCH v2] Add stty(1)
- [hackers] [ubase][PATCH] Add nologin(8)
- [hackers] [ubase][PATCH] Add pwdx(1)
- [hackers] [ubase][PATCH] Add setsid(1) from sbase with -c added
- [hackers] [ubase][PATCH] Add shred(1)
- [hackers] [ubase][PATCH] Add stty(1)
- [hackers] [ubase][PATCH] fsfreeze: make it clear the either -f or -u must be specified, not optional
- [hackers] [ubase][PATCH] Makefile: add pwdx.1
- [hackers] [ubase][PATCH] pwdx: fix off-by-one bug
- [hackers] [ubase][PATCH] shred: call fsync at the end of each
- [hackers] [ubase][PATCH] shred: call fsync at the end of each content shred pass
- [hackers] [ubase][PATCH] stty belongs in ubase
- [hackers] Compiling stali
- [hackers] st: Fix off-by-one error when calculating character width.
- Last message date: Thu Mar 31 2016 - 18:24:48 CEST
- Archived on: Thu Nov 21 2024 - 10:48:47 CET